Главная arrow ГДЗ arrow Информатика 6 класс Босова Л.Л. 2013 arrow §18 Управление исполнителем Чертёжник ответы на "Вопросы и задания"

§18 Управление исполнителем Чертёжник ответы на "Вопросы и задания"

Управление исполнителем Чертёжник Вопросы и задания, Информатика 6 класс Босова Вопросы и задания, Информатика 6 класс Босова ответы на вопросы, Информатика 6 класс Босова ГДЗ, Информатика 6 класс Босова ответы

Задание 1
Охарактеризуйте исполнителя Чертёжник.
Решение
Исполнитель Чертёжник предназначен для построения рисунков на координатной плоскости. Рисунки Чертёжник выполняет с помощью команд сместиться в точку и сдвинуться на вектор. Чертёжник имеет перо, которое можно поднимать, опускать и перемещать. При перемещении опущенного пера за ним остаётся след - отрезок от предыдущего положения пера до нового. При перемещении поднятого пера никакого следа на плоскости не остаётся. В начальном положении перо Чертёжника всегда поднято и находится в точке (0, 0).

Задание 2
Составьте для Чертёжника алгоритм рисования прямоугольника со сторонами, параллельными осям координат, если известны координаты его двух вершин: (2, 1) и (7, 5).
Решение
Image

сместиться в точку (2, 1)
опустить перо
сместиться в точку (2, 5)
сместиться в точку (7, 5)
сместиться в точку (7, 1)
сместиться в точку (2, 1)


Задание 3
Составьте алгоритм управления Чертёжником, в результате выполнения которого в произвольном месте координатной плоскости будет нарисован квадрат, длина стороны которого равна 2 единицам.
Решение
сместиться в точку (n, m)
опустить перо
сместиться на вектор (2, 0)
сместиться на вектор (0, 2)
сместиться на вектор (- 2, 0)
сместиться на вектор (0, - 2)


Задание 4

Составьте алгоритм управления Чертёжником, в результате выполнения которого в произвольном месте координатной плоскости будет нарисован прямоугольник, длины сторон которого равны 3 и 4 единицам.
Решение
сместиться в точку (n, m)
опустить перо
сместиться на вектор (3, 0)
сместиться на вектор (0, 4)
сместиться на вектор (- 3, 0)
сместиться на вектор (0, - 4)


Задание 5
Составьте алгоритм рисования изображенных ниже фигур так, чтобы в процессе рисования перо не отрывалось от бумаги и ни одна линия не проводилась дважды.
Image
Решение
а) опустить перо
сместиться в точку (0, 4)
сместиться в точку (4, 4)
сместиться в точку (0, 0)
сместиться в точку (4, 0)
сместиться в точку (4, 4)
сместиться в точку (8, 4)
сместиться в точку (4, 0)
сместиться в точку (8, 0)
сместиться в точку (8, 4)


б) сместиться в точку (2, 2)
опустить перо
сместиться в точку (0, 2)
сместиться в точку (0, 6)
сместиться в точку (4, 6)
сместиться в точку (4, 2)
сместиться в точку (2, 2)
сместиться в точку (2, 4)
сместиться в точку (6, 4)
сместиться в точку (6, 0)
сместиться в точку (2, 0)
сместиться в точку (2, 2)


в) сместиться в точку (1, 0)
опустить перо
сместиться в точку (4, 6)
сместиться в точку (7, 0)
сместиться в точку (0, 4)
сместиться в точку (8, 4)
сместиться в точку (1, 0)


Задание 6
Оформите вспомогательные алгоритмы для рисования букв «М», «И», «Р». Составьте алгоритмы рисования слов «МИР», «РИМ», «МИМ».
Image
Решение

АЛГОРИТМ БУКВЫ М
алг буква_М
нач
   опустить перо
   сместиться на вектор (0, 4)
   сместиться на вектор (1, - 2)
   сместиться на вектор (1, 2)
   сместиться на вектор (0, - 4)
   поднять перо
   сместиться на вектор (1, 0)
кон


АЛГОРИТМ БУКВЫ И

алг буква_И
нач
   поднять перо
   сместиться на вектор (0, 4)
   опустить перо
   сместиться на вектор (0, - 4)
   сместиться на вектор (2, 4)
   сместиться на вектор (0, - 4)
   поднять перо
   сместиться на вектор (1, 0)
кон


АЛГОРИТМ БУКВЫ Р
алг буква_Р
нач
   опустить перо
   сместиться на вектор (0, 4)
   сместиться на вектор (2, 0)
   сместиться на вектор (0, - 2)
   сместиться на вектор (- 2, 0)
   поднять перо
   сместиться на вектор (3, - 2)
кон


АЛГОРИТМ СЛОВА МИР
использовать Чертежник
алг слово МИР
нач
   буква_М
   буква_И
   буква_Р
кон


АЛГОРИТМ СЛОВА РИМ
использовать Чертежник
алг слово РИМ
нач
   буква_Р
   буква_И
   буква_М
кон


АЛГОРИТМ СЛОВА МИМ
использовать Чертежник
алг слово МИМ
нач
   буква_М
   буква_И
   буква_М
кон


Задание 7
Разработайте вспомогательный алгоритм рисования домика. На его основе составьте основной алгоритм рисования улицы из пяти домиков.
Image
Решение
АЛГОРИТМ РИСОВАНИЯ ДОМА
алг дом
нач
   опустить перо
   сместиться на вектор (2, 2)
   сместиться на вектор (2, - 2)
   сместиться на вектор (- 4, 0)
   сместиться на вектор (0, - 3)
   сместиться на вектор (4, 0)
   сместиться на вектор (0, 3)
   поднять перо
   сместиться на вектор (- 1, - 1)
   опустить перо
   сместиться на вектор (- 2, 0)
   сместиться на вектор (0, - 1)
   сместиться на вектор (2, 0)
   сместиться на вектор (0, 1)
   поднять перо
кон


АЛГОРИТМ РИСОВАНИЯ 5 ДОМОВ
использовать Чертежник
алг ряд домов нач
   сместиться в точку (1, 3)
   нц 5 раз
      опустить перо
      дом
      поднять перо
      сместиться на вектор (2, 1)
   кц
кон


Задание 8
Составьте алгоритмы управления Чертёжником, после исполнения которых будут получены следующие рисунки:
Image
Решение
а) алг квадрат_1
нач
   опустить перо
   сместиться в точку (6, 0)
   сместиться в точку (6, 6)
   сместиться в точку (0, 6)
   сместиться в точку (0, 0)
   поднять перо
кон


б) алг квадрат_2
нач
   сместиться в точку (1, 0)
   нц 5 раз
      опустить перо
      сместиться на вектор (0, 6)
      сместиться на вектор (- 1, 0)
      сместиться на вектор (0, - 6)
      сместиться на вектор (1, 0)
      поднять перо
      сместиться на вектор (1, 0)
   кц
   опустить перо
   сместиться на вектор (0, 6)
   сместиться на вектор (- 1, 0)
   сместиться на вектор (0, - 6)
   сместиться на вектор (1, 0)
   поднять перо
кон


в) алг квадрат_3
нач
   сместиться в точку (1, 0)
нц 5 раз
   нц 5 раз
      опустить перо
      сместиться на вектор (0, 1)
      сместиться на вектор (- 1, 0)
      сместиться на вектор (0, - 1)
      сместиться на вектор (1, 0)
      поднять перо
      сместиться на вектор (1, 0)
   кц
   опустить перо
   сместиться на вектор (0, 1)
   сместиться на вектор (- 1, 0)
   сместиться на вектор (0, - 1)
   сместиться на вектор (1, 0)
   поднять перо
      сместиться на вектор (- 5, 1)
кц
нц 5 раз
      опустить перо
      сместиться на вектор (0, 1)
      сместиться на вектор (- 1, 0)
      сместиться на вектор (0, - 1)
      сместиться на вектор (1, 0)
      поднять перо
      сместиться на вектор (1, 0)
   кц
сместиться на вектор (0, 1)
сместиться на вектор (- 1, 0)
сместиться на вектор (0, - 1)
сместиться на вектор (1, 0)
кон


Задание 9
Составьте алгоритмы управления Чертёжником, после исполнения которых будут получены следующие рисунки:
Image
Решение
АЛГОРИТМ МАЛЕНЬКИЕ КВАДРАТЫ
алг квадраты_1
нач
   нц 5 раз
      опустить перо
      сместиться на вектор (2, 0)
      сместиться на вектор (0, 2)
      сместиться на вектор (- 2, 0)
      сместиться на вектор (0, - 2)
      поднять перо
      сместиться на вектор (3, 0)
         опустить перо
         сместиться на вектор (1, 1)
         сместиться на вектор (- 1, 1)
         сместиться на вектор (- 1, - 1)
         сместиться на вектор (1, - 1)
      поднять перо
   кц
кон


АЛГОРИТМ БОЛЬШИЕ КВАДРАТЫ
алг квадраты_2
нач
   нц 4 раз
      опустить перо
      сместиться на вектор (2, 0)
      сместиться на вектор (0, 2)
      сместиться на вектор (- 2, 0)
      сместиться на вектор (0, - 2)
      поднять перо
      сместиться на вектор (4, - 1)
         опустить перо
         сместиться на вектор (2, 2)
         сместиться на вектор (- 2, 2)
         сместиться на вектор (- 2, - 2)
         сместиться на вектор (2, - 2)
      поднять перо
   кц
кон


АЛГОРИТМ ПРЯМОУГОЛЬНИКИ
алг прямоугольники_1
нач
   нц 5 раз
      опустить перо
      сместиться на вектор (0, 1)
      сместиться на вектор (- 3, 0)
      сместиться на вектор (0, - 2)
      сместиться на вектор (3, 0)
      сместиться на вектор (0, 1)
      
      сместиться на вектор (- 1, 0)
      сместиться на вектор (0, - 2)
      сместиться на вектор (3, 0)
      сместиться на вектор (0, 2)
      сместиться на вектор (- 2, 0)
      поднять перо
      сместиться на вектор (4, 0)
   кц
кон


АЛГОРИТМ УЗОР
алг часть_1
нач
   нц 4 раз
      опустить перо
      сместиться на вектор (0, 2)
      сместиться на вектор (2, 0)
      поднять перо
      сместиться на вектор (- 3, - 1)
   кц
кон


алг часть_2
нач
   нц 4 раз
      опустить перо
      сместиться на вектор (0, 2)
      сместиться на вектор (- 2, 0)
      поднять перо
      сместиться на вектор (3, - 1)
   кц
кон

алг часть_3
нач
   нц 4 раз
      опустить перо
      сместиться на вектор (2, 0)
      сместиться на вектор (0, 2)
      поднять перо
      сместиться на вектор (- 1, - 3)
   кц
кон

алг часть_4
нач
   нц 4 раз
      опустить перо
      сместиться на вектор (0, - 2)
      сместиться на вектор (2, 0)
      поднять перо
      сместиться на вектор (- 3, 1)
   кц
кон

использовать Чертежник
алг узор_1
нач
   часть_1
   сместиться на вектор (5, - 5)
   часть_2
   сместиться на вектор (- 3, - 7)
   часть_3
   сместиться на вектор (- 7, 3)
   часть_4
кон


АЛГОРИТМ УЗОР 2
использовать Чертежник
алг узор_2
нач
   часть_3
   сместиться на вектор (4, 3)
   часть_4
   сместиться на вектор (1, - 6)
   часть_1
   сместиться на вектор (- 9, 2)
   часть_2
кон


Задание 10
Придумайте свои задачи для Чертёжника.
Решение
Image
АЛГОРИТМ ЧЕЛОВЕКА
алг человек
нач
   опустить перо
   сместиться на вектор (0, 8)
   сместиться на вектор (2, 0)
   сместиться на вектор (0, - 8)
   сместиться на вектор (- 2, 0)
   
   поднять перо
   сместиться на вектор (0, 3)
   опустить перо
   сместиться на вектор (- 1, 0)
   сместиться на вектор (0, 1)
   сместиться на вектор (1, 2)
   сместиться на вектор (2, 0)
   сместиться на вектор (1, - 2)
   сместиться на вектор (0, - 1)
   сместиться на вектор (- 1, 0)
   
   поднять перо
   сместиться на вектор (0, 1)
   опустить перо
   сместиться на вектор (1, 0)
   
   поднять перо
   сместиться на вектор (- 4, 0)
   опустить перо
   сместиться на вектор (1, 0)
   
   поднять перо
   сместиться на вектор (0, - 2)
   опустить перо
   сместиться на вектор (2, 0)
   
   поднять перо
   сместиться на вектор (- 1, 0)
   опустить перо
   сместиться на вектор (0, - 2)
   поднять перо
кон


Теоретическая часть